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38. Administrative Tool & Part 11 

38.1  Introduction 
Historically, QC-CALC Real-Time has been used within an individual inspection 
machine as a single copy of software. Each person controlled and adjusted QC-
CALC’s operation individually. As networks became more prevalent, the 
inspection devices were connected to the network making data movement 
easier. This created the need to control the individual copies of QC-CALC 
running throughout the shop from a central location. 
 
The Administrative Tool helps the Quality Department set up and control every 
copy of QC-CALC within the entire company. This tool can be activated and used 
from any of the QC-CALC copies on the network.  
 
In addition, the medical supply companies must satisfy FDA title 21 Code of 
Federal Regulations (CFR21 Part 11) Electronic Records; Electronic Signatures, 
as it applies in a medical manufacturing environment. A special section has been 
added to this document which describes how QC-CALC can be configured to 
help you meet the requirements of Part 11. 
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38.2  Setup and Installation Instructions 

38.2.1 Introduction 

There are several installation options for QC-CALC. You can install the standard 
QC-CALC.You can use a System Management Server such as Microsoft’s SMS 
or Altiris’ Service-Oriented Management solution. Both of these programs can 
be used to install multiple copies of QC-CALC throughout your company at the 
same time. By using our batch file commands, you can run these installations in 
silent mode or allow the user to see the installation on their local screen. 
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38.3  Silent Install 
The installation of QC-CALC (Administrative Copy) can be automated to a point 
where no questions are asked. Optionally, you can run the install in a silent mode 
where no screens are displayed. This type of installation requires a batch file that 
contains instructions to tell QC-CALC what to do and how to do it.  
 
Normally, this type of automated installation is used in companies where the IT 
department “rolls out” the installation from a central server. This type of install 
reduces time and increase control in physically large companies. 
 
You can use a System Management Server such as Microsoft’s SMS or Altiris’ 
Service-Oriented Management solution. Both programs can be used to install 
multiple copies of QC-CALC throughout your company at the same time. By 
using our batch file commands, you can run these installations in silent mode or 
allow the user to see the installation on their local screen.  
 

Note: In all cases, an installation screen will appear briefly during the installation 
process. Following this, a progress bar will be displayed. This is meant as a 
visual cue that the install is taking place. 

38.4  Setup Batch File 

38.4.1 The Batch File Location 

The batch file needed to automate QC-CALC’s installation should be located on 
a shared server that is accessible to all shop floor PCs.  

38.4.2 The Batch File Contents 

The batch file consists of one line starting with the server path and the install .exe 
followed by optional arguments. The following shows the contents of an example 
file called QCCALC41.BAT. Keep in mind this is one long command even though 
it appears on multiple lines. All arguments are separated by (;) semi-colons with 
no extra <spaces>. 
 
If you omit any of the arguments below, the corresponding installation screen will 
appear asking the user to provide this information.  
 
S:\Prolink_Install\QCCALCDemo41.EXE /silent; 

destinationpath=C:\Program Files (x86)\Prolink\QC-CALC 4.1\; 

adminpath=H:\SPC\Admin\;usergroup=Operator;username=Bruce; 

companyname=My Co.;plsserver= Prolink1;plsport=5928; 
plspassword=;theme=Office 2010 Style;activationpref=RT 

 

Batch File Command Item Comments 

S:\Prolink_Install\__.EXE Name of the install file downloaded from the Prolink 
website. Must be followed by a <space> and /silent. 

/silent; If this switch is present, the installation process is not 
visible on the target PC. If this switch is omitted, the 
InstallShield screen is displayed and someone will have to 
click the installation wizard’s Next > button to continue the 
setup. The answers to the wizard’s questions would be 
filled in by the contents of the batch file but you should 
include the /silent switch. 

destinationpath=____; This is the installation path where QC-CALC will be 
installed in the CMM or gaging station. You can change it 
to whatever path you desire. The default path is: 

C:\Program Files (x86)\Prolink\QC-CALC 4.1\ 
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adminpath=H:\SPC\Admin\; This is the folder used to control all QC-CALCs in your 
facility. All common settings are stored here. You should 
standardize on the location by using a batch file like this 
one.  

usergroup=Operator; This command sets the active user group when the 
installation is complete. This command will work if you set 
up one copy of QC-CALC on your desktop PC and created 
this user groups first.  

username=Bruce; Sets the user name into QC-CALC. This name appears on 
some reports. 

companyname=My Co.  Sets the company name into QC-CALC. This name 
appears on some reports. 

plsserver=Prolink1 This is the server name where Prolink License Server 
(PLS) is installed. No slashes or drives, just the server 
name. 

plsport=5928 This is an internal value and is defaulted to 5928.  

plspassword= An optional password set in the PLS program. The 
passwords must match. This prevents uncontrolled 
installations. 

theme= You can specify the Theme to be used by QC-CALC. The 
value entered here must exactly match an item from the list 
in the Tools > Options > Global > Themes area.  

activationpref=RT 

 
e.g. 
 
activationpref=CALC 
activationpref=RT 
activationpref=SPC 
activationpref=GS 

QC-CALC has an additional activation preference flag 
called activationpref. Possible values for the activationpref 
are: 
 
 
QC-CALC Enterprise (SPC & RT) 
QC-CALC Real-Time only 
QC-CALC SPC only 
GageStation (QC-CALC Real-Time & QC-Gage) 

 

Note: adminpath and usergroup only apply to QC-CALC and QC-Gage 
installations. 
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38.5  Manage User Groups 
For simplicity reasons, QC-CALC does not save administrative settings at the 
user level. Instead, groups are created with default settings and locked from 
being changed. Copies of QC-CALC are then assigned to these groups. It is not 
necessary to log in as a particular user in order to obtain your group settings 
since groups are assigned at the PC level. It is assumed that all users using a 
particular PC are in the same group. This form of security was chosen because 
QC-CALC runs without human intervention. It is critical not to interrupt data 
collection due to login errors. 
 

Note: Individual user id/password combinations are assigned to individual 
persons for Part 11 related activities such as auditing and the digital signing of 
reports. Please see the CFR21 Part 11 Considerations section on page 259 for 
details.  

38.6  Create User Groups 
After enabling the Administrative Tools menu, User Groups need to be 
created. 
 

1. To access the User Group Manager, select the Administrative Tools > 
Manage User Groups menu and enter your password 

 

2. To create a new user group, click the Add button. The screen below will 
appear describing the process involved in the screens following. 

 

3. Enter a name for the User Group you want to create. For our examples 
below we entered CMM Users. 
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4. To configure the settings that you want the computers in your group to follow, 
select your group from the list and click the Manage Group button.  

 

38.6.1 Manage Group 

The Manage Group button is used to set the configurations applied to all 
computers within a group and therefore establish the look and feel of each QC-
CALC in the group.  

Select Common Settings 

The Settings screen when managing user groups is similar to the Tools > 
Options screen. There is an additional Hand button at the bottom of the window 
and two additional items in the list on the left labeled Menu System Manager 
and Part 11. To lock a setting, change any option to the desired value, click the 
Hand button, and click the option. The option becomes purple which indicates it 
cannot be changed by the user.  
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Lock the Settings 

When the Hand button is depressed and you float the mouse over any option, 
the item is temporarily outlined with a purple square. Clicking on the item while 
the purple square is shown causes the item to turn fully purple indicating it is 
locked.  

 

Note: Any file settings needing global access such as Assignable Causes, 
Corrective Actions, Filters, and the Update location should be set so that all 
computers use the same files. This ensures the entire company uses the same 
settings. You set these items in this configure window. 

The Hand Button 

Change all settings to values that make sense for your company and use the 
Hand button to lock all values you want restricted from the Group. 

 

In this example the Calculation was set to Cpk and then locked so all computers 
in the group display the Cpk value in the lower left corner of each plot. The 
computers in the Group cannot change this setting since you locked it. 
 

TIP: By default, the Hand button stays depressed allowing you to select many 
items until you click the Hand button again. 

Menu System Manager 

All menus can be disabled and/or checked from the Menu System Manager in 
the Manage Options screen. There is no need to use the Hand button on this 
particular screen. Simply check the box in the Disabled column for the menus 
you want to disable for the particular group you’re currently editing.  
 
You may also disable or enable an entire subcategory of menu items by checking 
the box on lines for main categories such as File, Properties, View, etc.  
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In the picture below, the File > Exit menu was disabled. With this setting, a user 
hitting the X button will be prompted to enter a password to exit the program. 
Additionally View > Bottom Status Bar was checked (so that status bar will be 
displayed), and View > Point Properties was checked to be displayed and 
disabled so no one can shut it off. 

 

38.7  Edit Application Defaults 
The Edit Application Defaults selection gives the administrator the ability to 
modify the default values for QC-CALC Real-Time. Normally, these values do not 
need to be modified but they can be under certain conditions. The most 
commonly changed default values are surrounded with red.  
 
Choose the Administrative Tools > Edit Application Defaults menu to display 
this window. 

 

To modify the values in the boxes simply double click on the item on the right 
side in the grid you wish to change. This displays a dialog box with the current 
value that can be changed. 
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Be sure that you follow the current format in the box, for example if it is a number 
you can only change it to another number. If it is a folder path you can only 
change it to a new path and so on. If the format changes and you click OK, you 
will get an error message saying An Invalid Input value was entered and you 
will have to change it. 
 

Note: Changing default values that are numbers is much simpler than changing 
the paths (C:\QVSI\BasicX\Config\) or any of the values that have pipes (|) in 
them. You have to be very careful because you can change those values, and 
QC-CALC may not know your value is invalid. 

38.8  Set Current User Group 
Once the User Groups are created and the options are locked for each group, 
you activate the group by selecting it from the User Group list and clicking Set 
Group. This should be a one-time change and QC-CALC will remain with this 
active user group. 

38.9  Logout 
When you enter your password to modify anything in the Administrative Tools, 
there is a checkbox saying Keep me logged in. Once you check this you can 
modify multiple settings without re-typing your password each time. If you clicked 
the checkbox to stay logged in, the Logout feature under the Administrative 
Tools menu is used to cancel the edit feature. Closing QC-CALC and restarting it 
will also logout the admin account. 

38.10  Disconnecting from Admin Path 
The Disconnect from Admin Path menu allows you to leave the Administrative 
settings you’re currently connected to. You will be prompted to enter your admin 
password before you can disconnect the path. This will also remove the 
Administrative Tools menu until reconnected as an admin. 
 
If you need to reconnect to the admin path, click Tools > Enable Administrative 
Tools which will take you back through the Administrative Tools Setup. This 
will also re-enable the Administrative Tools menu upon setup completion. 

38.11  Troubleshooting 

Administrative Tools Menu Not Visible 

If you do not see the Administrative Tools menu when you start QC-CALC, it 
means QC-CALC no longer has access to the central admin settings folder. If 
QC-CALC was installed correctly then check the following:  
 

• Check to make sure the local Windows user currently logged in has 
access to the central administrative folder.  

• If you are using mapped drive letters, make sure the drive letter originally 
specified is still pointing to the same shared directory on the network. 
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The User Group Path is shown at the top of the User Group Manager window. 

 

38.12  CFR21 Part 11 Considerations 

38.12.1 Introduction 

This section describes QC-CALC’s operation as it pertains to the FDA title 21 
Code of Federal Regulations (21CFR Part 11) requirements. It discusses how 
QC-CALC is configured to meet the high-level requirements of Part 11.  
 
In order to run QC-CALC in Part 11 Mode, you must enable Administrative Tools 
due to the control nature of the Part 11 requirements. Part 11 settings are stored 
at the group level, so you will find the settings screen for Part 11 in the Manage 
Options window of each group.  

38.12.2 Trackable Changes 

The Part 11 Auditing features track all changes made to data after it is collected. 
Each time a change is made, the user making the change is required to enter 
their username, password, and select a Reason Code indicating the reason for 
that change. These changes require authentication: 
 

1. Changes to the actual value measured 
2. Changes to the measure date or time of the measurement 
3. Changes to the value of any trace field  
4. Deletions/un-deletions of individual points 
5. Deletions/un-deletions of records (parts) 
6. Re-measurement of a part 
7. Additions or removals of assignable causes 
8. Additions or removals of corrective actions 

38.12.3 The Setup 

The setup of Part 11 Auditing requires you to: 
 

• Create User Groups Administrative Tool pg. 254 

• Set the Options for each Group Administrative Tool pg. 255 

• Add Users to the Groups Part 11 Setting pg. 261 

• Enter Reason Codes Part 11 Setting pg. 263 

• Enable Auditing Part 11 Setting pg. 263 
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Begin the Part 11 setup by selecting the Administrative Tools > Manage User 
Groups menus. Add as many user groups as necessary. You will see (None) as 
the default until other named user groups are added. 

 

Select the user group before clicking the Manage Group button. Set and lock the 
common options for each group as discussed in the previous section. 
 
To setup the Part 11 options, choose the Part 11 option on the left side to see 
the following screen:  
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38.12.4 Adding Users to the Group 

You use the User tab and the Add button to add individual people to your 
groups. Each person requires a name and password. You may also add a 
graphic signature file to the user record. This is optional and can be placed on 
digitally signed PDF reports. 

 

Note: Graphic signature files are digitally stored within QC-CALC for security 
reasons. As such, there is a 100K byte size limit to each uploaded image.  

 

Users are not group specific and are shared across all groups. 

38.12.5 LDAP 

You cannot add Users if you choose LDAP as discussed in the LDAP 
(Lightweight Directory Access Protocol) section on page 269.  
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38.12.6 Account Management 

The Account Management tab has options for account deactivation, failed login 
attempts, and managing active and inactive accounts. If you are using LDAP to 
authenticate users these options do not apply and will be disabled.  

 

Account Deactivation Notification 

If this box is checked, an email will be sent to the address specified whenever an 
account is deactivated 

Account Deactivation 

Deactivate Account after exceeding authentication attempts 

If this box is checked, an account will be activated after a certain number of failed 
attempts to access it. You can set the number of attempts in the box immediately 
below 

Log failed authentication attempts 

If this box is checked, all failed authentication attempts will be logged and can be 
reported on with other audit trail records. 

Enforce password expiration 

This allows you to set up password expiration for all accounts at the same time 
instead of needing to do it individually.  
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Adding Reason Codes to the Group 

Along with authenticating username and password, users must select a Reason 
Code when making changes to existing data. Reason Codes cannot be added at 
the time of authentication. 

 

Reason Codes are shared across all groups. The maximum length of a reason 
code is 64 characters. 

38.12.7 Challenge Users 

The top section of the Part 11 area controls how users are challenged when 
collecting or editing values.  

 

Challenge users when making changes to existing values 

This option enables the auditing system in general. Users will be required to 
provide a username, password, and reason code when attempting any of the 
trackable changes. See the Trackable Changes section on page 259 for more 
details. 

Challenge users as new data is received 

Checking this option will require users to provide a username and password as 
new data is collected. 

Show ‘Remember Login Info’ checkbox 

This option enables users to enter their username and password once and have 
it remembered. 

Session User 

The Session User area enables settings that change based on the user that logs 
in to the software. As Users are being configured, they are added to specific 
User Groups and then when QC-CALC is launched the user will be asked to 
enter their User Name and Password. QC-CALC will use this information to 
determine which User Group should be loaded and the appropriate settings will 
be applied to that session. 
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Use currently logged on Windows ID 

This option will automatically use the Windows ID, but that ID MUST match a 
User Name in the list of Users in the Admin Tool.  

Prompt for User Name and Password 

As QC-CALC launches the operator will be asked to enter their User Name 
and Password and the appropriate settings will be loaded based on that user 
information. This User Name will also be entered into the challenge screen 
so the user will only have to enter their password. 

Do not challenge for a password 

With this option checked the operator will not be asked to enter any 
information as new data is received. The value entered during the QC-CALC 
loading process will be used for all challenge answers. 

 

Note:  The Enable Auditing setting is NOT shared across all groups and must 
be set for each group that requires it.  

38.12.8 Editing the Data 

Editing tools were added to QC-CALC to help you fix bad readings. Please 
recognize Prolink makes a distinction between bad readings vs. bad parts. When 
a gage saves a reading that must be changed due to gaging errors, the Part 11 
tools described here help control the “who, what, and why” of the change that 
was made. 
 
Right-clicking on a point in QC-CALC Real-Time yields the familiar pop-up menu 
shown below.  
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Selecting Point Properties allows you to edit the value as shown. 

 

38.12.9 Documenting the Change 

When you finish changing the value, press the ENTER key or the F6 key, or 
close the Point Properties panel. At this point the Part 11 Audit box appears 
requesting information. You must complete this dialog or your changes are 
discarded! 
 
Select your name from the User Name list, enter your Password, and select a 
Reason Code from the list. Click OK and your changes are saved. If you do not 
complete this sequence or press Cancel, your changes are discarded. 

 

Once the challenge is answered, the edited point turns navy blue and is bold in 
the Point Properties panel. This is your visual clue the value has been edited. 
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38.12.10 CFR Part 11 Audit Report 

You can generate a report containing all changes made to a part file by printing a 
special report included in the Real-Time report list called the “CFR Part 11 Audit 
Report.” This report is generated the same as all other Real-Time reports, but it 
contains the pertinent audit trail information as required by Part 11. To open the 
Manual Report Settings menu, click Report > Print Report, and from here you 
can edit and save the settings required for your CFR Part 11 Audit Report. 

 

Signed Reports PDF Only 

You must print signed reports to File and select a File Type of Adobe PDF 
Format Signed in order to see your signature. If the file has been tampered with, 
it will say so. Change the File Name and location to the appropriate name and 
click OK. The PDF file has properties that you can review. 
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PDF File Signature Properties 

The tamper proof signature is found in the signature section of the final PDF file. 
Clicking the Signature button reveals the status of the file. QC-CALC adds the 
password protected username to the document and includes the Reason Code 
they chose. If the file is modified in any way, the signature property indicates it is 
a tampered file. 
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38.12.11 Sample Audit Report 

This sample audit report shows the detail necessary to trace any changes to any 
QC-CALC database. It includes the original value before the edit and the new 
value. All editable items in the database are added to this report. You can print 
this report for an individual point by right-clicking on the point and selecting the 
Print Report menu. A history of that one point (part) is printed. 
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38.12.12 LDAP (Lightweight Directory Access Protocol) 

QC-CALC has a built-in User > Password system but some organizations 
require these account names be stored and managed at the company level 
instead. The chosen standard is an LDAP server. For such organizations, QC-
CALC provides a simple interface.  
 
When the Use LDAP to authenticate users option is checked, the contents of 
the Users tab changes to reflect the LDAP settings instead. You will need to 
contact your IT department to setup the required “connection string”. When 
changes are made or new data is collected you are asked for your User Name 
and Password. You must enter your company logon name and password 
instead of any identification you may have entered into the QC-CALC system. 

 

Signature Pictures can be added within the QC-CALC system by adding the 
LDAP user name and the picture to associate with that user.  
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